Back to overview
Resolved

Card payment processing degraded

May 23, 2026 at 8:00pm UTC
Affected services
Centrix Payment Processor

Resolved
May 24, 2026 at 4:00am UTC

Card payment processing has fully recovered. We are continuing to monitor.

Updated
May 24, 2026 at 12:00am UTC

We have identified the cause and are preparing a fix.

Created
May 23, 2026 at 8:00pm UTC

We are investigating intermittent issues with card payments. Some transactions may be delayed or fail during this period.