Back to overview
Resolved

Service outage caused by upstream provider

May 8, 2026 at 7:00am UTC
Affected services
Centrix Dashboard
Centrix Infrastructure

Resolved
May 8, 2026 at 8:15am UTC

Incident resolved. All services have been fully restored. We are continuing to monitor closely to ensure stability and confirm no residual impact. Thank you for your patience.

Updated
May 8, 2026 at 7:52am UTC

Partial recovery in progress. Service provider has restored part of the affected capacity. Centrix Infrastructure and Dashboard are operating in degraded mode while remaining traffic is being rerouted.

Created
May 8, 2026 at 7:00am UTC

We are currently experiencing a full outage on Centrix Infrastructure and Dashboard. The incident is caused by an issue with one of our service providers. Our team is investigating and coordinating with the provider.